harsh deshmukh
asked 6 years ago

Hi All,
Acoount activation emails are going to spam folder.. I went through below links but nothing is working at this moment. 
http://wordpress.org/support/topic/plugin-wp-members-all-mails-are-going-to-spam-folders-of-my-registered-userswhy?replies=2
http://wordpress.org/support/topic/plugin-wp-members-all-mails-are-going-to-spam-folders-of-my-registered-userswhy?replies=2

I have installed WP-Mail-SMTP and WP Better Emails as well. To stop spamming.

Can anyone help me on this.

Regards,
Harsh

5 Answers
well wisher
answered 6 years ago

Did you tried providing authentication when using smtp?

harsh deshmukh
replied 6 years ago

No I did not…

Actually I don't know how to set up authentication. If you see below screenshot there is a user name and password field. I don't know what should I put the value for these fields in case of my site.

Guru
answered 6 years ago

Dear Harsh,

I guess alot of your problems can be solved if you use User Pro plugin for your project. It will provide solutions to alot of the answers to problems you have asked via questions.

Jackie Lord
answered 6 years ago

@harsh031
Based on your mentions, I think this problem is not caused by WordPress or the Plugins.
You start getting the spam emails because your domain is not enough trust. Therefore, your mail box will mark them as spam. Please try Mandrill service to send the emails: http://mandrill.com/
Hope that this solution will help you resolve this.

harsh deshmukh
replied 6 years ago

Hi Jackie,

Thanks for your response However I want to know why things are working fine after deactivating this plugin. I can see all the registration email (using default registration form) and other emails are going to actual inbox folder.

It means there is some thing in the plugin that is causing the issue..

Regards,
Harsh

well wisher
answered 6 years ago

Hi for setting authentication you need to enter your email id and password and set the port 465 for using google smtp server just setup a new gmail id just for sending the emails as you need to enter this in the text field provided for authentication purpose

harsh deshmukh
replied 6 years ago

Hi well Wisher,

Thanks for the info. I am able to set up SMTP. I need to work further to check the spamming issue.

Regards,
Harsh

harsh deshmukh
replied 6 years ago

Google is stopping me to send emails via its SMTP server. I am getting emails i.e some one else is trying to access your email accounts.

Regards,
Harsh

well wisher
replied 6 years ago

you need to be logged in your gmail account the very first time you try and send the mails using its smtp server after that it will work fine

harsh deshmukh
replied 6 years ago

Hi Well wisher,

I really not able to connect through SMTP. And Still all my emails are moving into Spam folder. If You have time can you please look into my site and check why I am not able to connect through SMTP host.(please send me a test email on wardhan031@gmail.com)

SMTP Error: Could not connect to SMTP host.

I am following below settings.

https://wordpress.org/plugins/wp-mail-smtp/screenshots/.

Regards,
Harsh

well wisher
replied 6 years ago

ok could you please provide some screens for the settings page except the email and password parts !

well wisher
replied 6 years ago

try using the following ports 26 (Hostgator), 25, 465 and 587 and see if it works.Some service providers block default smtp ports !

harsh deshmukh
replied 6 years ago

I have already tried 25 for local host set up,465 for gmail and 587 for TLS encryption.

Please find the link as below.

https://www.dropbox.com/s/upvdr6l0ibj43wx/Smtp%20Setting.JPG

Regards,
Harsh

well wisher
replied 6 years ago

the settings seems all correct may be your webhost could help you resolve this problem better

Jackie Lord
answered 6 years ago

@harsh031: Please provide us your admin account (via private answer) for further checking.

harsh deshmukh
answered 6 years ago

Hi Jackie,
Thanks for considering my issue.
I went through lot of blogs and forums related to spam emails.
Finally I understood that It was due to the email format and content of my previous emails that i used to send for any topic update for my website. The content I was using in the email for any topic update was not well managed(latter I used Wp-better email). Hence google(gmail ) used to mark it as sapm and sending the topics to spam folder.
However I sent some 20-25 emails during testing of my site on some particular email address in very less span of time (may be gmail was considering it as bulk email messaging).
I tested my site for new registration using different email(gmail) address now things are going fine.
Note:
1. The eamil that I used for testing seems blocked form my own domain. I am not getting any email these days.
2. Rediff mail has never marked our email as spam.
3.Email notification( for dw- question answer) to all our previous users who are using gmail are still going to his spam folder.
Will update you if I find something more informative stuffs.
I just want to dig more before I share  the credentials with you.
Regards,
Harsh

Jackie Lord
replied 6 years ago

Currently, our DesignWall system frequently sends out the newsletters and notification emails. Are they marked as spam and sent to the spam folder?

Rafa Nadel
answered 5 years ago

Well there is a workaround for it, by using the pro version.
http://www.irctcloginsign.in/2014/12/gmail-login-sign-in-wwwgmailcom.html

Powered by DW Question & Answer Pro