Oren Margalit
asked 2 years ago

Hello,
When i enter a long comment in my site, the submit button disappears for some reason and the user cannot press on it. how can i fix this?
Greetings,
Oren
 

5 Answers
DominicStaff
answered 2 years ago

Please send me username & password of your site for further checking. I have checked on our demo and see that the plugin works fine, I think this issue come from another plugin. It’s a conflict between the plugins.

Oren Margalit
replied 2 years ago

how can i send you the details privately?

Dominic Staff
replied 2 years ago

You can use the private option here: http://prntscr.com/iik3po

DominicStaff
answered 2 years ago

To resolve this issue, you can add the following code to the style.css file: 

#respond #comment-form-comment textarea {
   height: 150px !important;
   overflow-y: scroll !important;
}
Oren Margalit
replied 2 years ago

that didn’t work. am i doing something wrong?

Dominic Staff
replied 2 years ago

You can try the following code in the style.css file.
Go to the Dashboard > Appearance > Editor.
.single-dwqa-question #respond #comment-form-comment textarea {
height: 100px !important;
overflow-y: scroll !important;
}

Oren Margalit
replied 2 years ago

how is that different from the initial answer?

Dominic Staff
replied 2 years ago

I think the code in the Customize section does not override in your site. In this case, you can try to insert the code to the style.css file or send me username & password of the admin account. I see that you are using another plugin for the comment box.

Oren Margalit
replied 2 years ago

i inserted the code you gave me to the css file and it didn’t help. is there any other way to solve the issue?

Dominic Staff
replied 2 years ago

Please give me the admin account to check your code site.

Oren Margalit
replied 2 years ago

username:
password:

Dominic Staff
replied 2 years ago

I can not access your site with this account. Please check your account.

Oren Margalit
replied 2 years ago

try the usernamewith the same password as above

facepush
replied 2 years ago

Just an FYI Your website information was not sent privately. Everyone here can see this.

Oren Margalit
replied 2 years ago

thank you very much, i changed the password. to dominic, how can i send you the new password privately?

facepush
replied 2 years ago

You may do so by using the Answer button at the bottom of this thread. From there you can change from Public to Private.

Hope this helps.

Oren Margalit
replied 2 years ago

again, thank you and bless you

rtra
answered 2 years ago

I have this issue too. Using Rowling theme. Tried adding the code in  Customising – ‘Additional CSS’ but it doesnt change anything. Any other suggestions? Many thanks

rtra
replied 2 years ago

Just to update this… the comments box works perfectly if commenting directly on the question, there isnt a big gap between the question and the first answer. But beneath each answer there is a big gap. When you add a comment to one of the answers, the comment expands into this big gap, but the space then doesnt further expand fast enough to accomodate longer comments, so eventually the ‘post comment’ button disappears behind the answer below it. Hope this helps

Dominic Staff
replied 2 years ago

You should send me your site URL for further checking. Also, the plugin does not compatible with the comment of jetpack plugin. It’s very hard to override CSS of this plugin. If you agree, you can provide the FTP account, I will check your issue.

DominicStaff
answered 2 years ago

@Oren Margalit: 
I have checked your site and see that you are using the Jetpack plugin. The Q&A plugin does not compatible with the comment of Jetpack plugin. Also, I have some mistake in your language and I have disabled the jetpack instead go to the setting. So, please help me configure the Jetpack plugin one more time. I will access and try to resolve this issue in the Today.

Oren Margalit
replied 2 years ago

for some reason the jetpack plugin isn’t working. actually he is not necessary i think. i see the issue is now resolved. only i need to enlarge the comment box in the Q&A section.

https://mikyab.net/%D7%94%D7%90%D7%9D-%D7%99%D7%A9-%D7%9E%D7%A2%D7%A9%D7%94-%D7%9C%D7%9C%D7%90-%D7%9E%D7%A0%D7%99%D7%A2-%D7%98%D7%95%D7%A8-120/

Dominic Staff
replied 2 years ago

You can go to the customize to change the size of the comment box, I have added the CSS code to the Custom CSS box.
See the screenshot: http://prntscr.com/ioqs0q

Oren Margalit
replied 2 years ago

but it didn’t work, the size of the comment box stayed the same.

Dominic Staff
replied 2 years ago

Please let me know the size that you want custom for the comment box.

Oren Margalit
replied 2 years ago

lets try 500 pixels

Dominic Staff
replied 2 years ago

Yes, I have helped you change the comment box to 500px, you can check your site now. If you want to change the size, you can go to the Customize > Custom CSS box.

Oren Margalit
replied 2 years ago

in regards to this problem. i have returned to the jetpack comments. is there anyway to keep the jetpack comments and still fix the issue?
greetings,

Dominic Staff
replied 2 years ago

At the moment, cannot use CSS to override the CSS of Jetpack comment. I will find another solution for this issue. I’m not sure about that. I will try and let you know.

Oren Margalit
replied 2 years ago

any news regarding this issue?

Dominic Staff
replied 2 years ago

At the moment, only a solution is to disable the CSS of Jetpack plugin and custom style for your site.

If you want to disable all the style of Jetpack plugin, you can add the following code to your functions.php file:
// First, make sure Jetpack doesn’t concatenate all its CSS
add_filter( ‘jetpack_implode_frontend_css’, ‘__return_false’ );

Then add the following code to your style.css file:

.dwqa-comment-form .comment-form textarea {
min-height: 50px;
height: 50px !important;
overflow-y: scroll !important;
}

NOTE: This solution will remove all the style of jetpack on front-end.

Oren Margalit
replied 2 years ago

where is the functions.php file located?

Dominic Staff
replied 2 years ago

you can go to the Dashboard > Appearance > Editor and find the functions.php file in the right-hand side.

Oren Margalit
replied 2 years ago

i didn’t find it. under Dashboard > Appearance there is no “Editor” option.

Dominic Staff
replied 2 years ago

See the screenshot: http://prntscr.com/jcn4sc
If you can not find the functions.php file in the Dashboard, you can use the FTP or Cpanel to edit the files.

Oren Margalit
replied 2 years ago

if i use the ftp, where is the functions.php file located?

Dominic Staff
replied 2 years ago

Connect via FTP to your server. Navigate to wp-content/themes//. You will find there the file functions.php

Oren Margalit
replied 2 years ago

i inserted the code and nothing was changed. am i doing something wrong?

Dominic Staff
replied 2 years ago

Please send me your FTP account for further checking.

Oren Margalit
replied 2 years ago

is it possible that you instruct me on what to do, and i will do it and report back?

Dominic Staff
replied 2 years ago

Very hard to check it. I have added the code to the functions.php file and see that it works fine.
You can send me your functions.php file for further checking.

Oren Margalit
replied 2 years ago

what do you mean by “works fine”?
what is changed when you insert the code?

Dominic Staff
replied 2 years ago

I can add the CSS code to override the style of Jetpack plugin. Just added the code to the functions.php file.
You can try the following code:
add_filter( 'jetpack_implode_frontend_css', '__return_false' );

Oren Margalit
replied 2 years ago

how do you add the code to the file?
just paste the line at the bottom of the code?

Dominic Staff
replied 2 years ago

Yes, just added the code to the bottom of the functions.php file.

Oren Margalit
replied 2 years ago

can you tell me the exact location of the functions.php file you are referring to?

Dominic Staff
replied 2 years ago

You should send me your functions.php file.
Connect via FTP to your server. Navigate to wp-content/themes//. You will find there the file functions.php

Oren Margalit
replied 2 years ago

i did this, but the only thing that was changed is that the sharing buttons (facebook, twitter etc) turned from boxes to regualr text links. the comment box stayed exactly the same.

Oren Margalit
replied 2 years ago

any news regarding this issue?

Oren Margalit
answered 2 years ago

here is a screenshot of the wp-content/themes folder content:
https://drive.google.com/open?id=1FQPNF0qGBpuoBlctcRgjAk3Xm-GRM8rZ
 
it does not contain a file named functions.php

Dominic Staff
replied 2 years ago

If you are using the Twenty Twelve theme, you can open this theme folder then find the functions.php file.
See the screenshot: http://prntscr.com/jge8we|
Then add the code to line 582.

Oren Margalit
replied 2 years ago

i did this, but the only thing that was changed is that the sharing buttons (facebook, twitter etc) turned from boxes to regualr text links. the comment box stayed exactly the same.

Oren Margalit
replied 2 years ago

any news regarding this issue?

Dominic Staff
replied 2 years ago

Very hard to check this issue. I can not check and help you resolve this issue. I tested on our site and this code can disable the CSS of Jetpack plugin.

Oren Margalit
replied 1 year ago

Hello again,
i was wandering if any new solution was found regarding my problem with the comment box overflowing in to hidden territory. i want to keep using jetpack and have the comment box showing correctly. there must be some code edit to solve this issue.

also another question, in the bottom of the single question page there is a navigation menu with “next question” and “previous question” links. what css code do i need to input in order to hide this menu?

Greetings,

Oren Margalit
replied 1 year ago

also i wanted to ask how do i change the background color of the comments

Dominic Staff
replied 12 months ago
Powered by DW Question & Answer Pro