Luca Ercoli
asked 6 years ago

Hi,

I have successfully installed the plugin on WordPress, I insert the link in the menu and try to write a question. “Error 404 page not found!”

I’m going to see on the administrative panel and technically everything is okay, the application has been created, but you can not see ..

I just installed this plugin and WP Maintenance Mode is currently active!

How can I solve this problem? Thank you very much!

John Long
replied 6 years ago

I am having issues with this as well but am unable to figure out how to make the “Post name” permalink option to work with this plugin. Any time I try to create a new question the page I receive is “Page not found”. It works fine if I am using the default permalink structure but I cannot use that structure. Any ideas?

aniketh
replied 6 years ago

Exactly my problem too. Waiting for an update. It appears to be working on designwall.com perfectly though! 😛

5 Answers
DominicStaff
answered 6 years ago

1. the 404 error page:
Please log in to Dashboard > Settings >Permalinks.
See the Screenshot:

To adjust DW Q&A plugin for your theme, please following the guide here: http://cmspioneer.com/designwall/guide/dw-question-answer-plugin/#installation

If you still there face issue, Please send me your site for further checking.

Luca Ercoli
answered 6 years ago

Hi,

Thank you so much for the support, quick and thorough!

I followed the procedure, the plugin is correctly installed but the same problem! Then I selected the Dashboard> Settings> Permalinks -> Default and everything worked properly.

I wanted to know if it was possible to run the plugin without the option of Default, for example, I use the custom structure.
 

 
EDIT: I updated the custom structure again and now it works correctly, thank you very much and happy holidays!

Cesar Falcao
replied 6 years ago

I´m in the same situation: this plugin looks awesome, but it´s not working (404 error for every answer) when using permalinks. Not using permalinks is not an option.

Cesar Falcao
replied 6 years ago

Just to add: I´m using a 3rd party theme.

Cesar Falcao
replied 6 years ago

And the “EDIT” option here doesn’t work too.

Hussain Al-saady
replied 5 years ago

Thanks Luca that fixed my problem too. Just setting it back to default and then post name again.

DominicStaff
answered 6 years ago

@John Long !
Please create a private question then send me username & password your site for further checking.

Ben Alex
replied 6 years ago

Hello, I am having the same issue. How do I go about getting help? Many thanks in advance

BigHug
answered 6 years ago

Hey guys,
Whenever you meet 404 error please go to Your Dashboard > Settings > Permalinks, Just click on “Save change” button. It will work.
About without running the default setting, we will discuss and improve it.

oracletuts
replied 6 years ago

Perfect! Helped me out, since I use a custom type of permalink.

Sowmini S K
answered 6 years ago

Hi,
This 404 page issue is resolved only if i change the permalink setting to default and save changes.
However, other menu items in my website will not work with the default url setting, due to slugs used in custom post types.
Is there some way, we can make this Q & A forum work for ‘post-name’ permalink as well (without which my website will not function normally)?
 
Thanks,
Sowmini

Sowmini S K
replied 6 years ago

Thanks team, for promptly fixing this permalink issue! Greatly impressed by your support, especially for a free plugin!!
Keep up the good work 🙂

DominicStaff
answered 6 years ago

You can create a private question then send me username & password of your site for further checking.

BigHug
answered 6 years ago

Hi Sowmini SK, 
Your problem was fixed, you can check in this link http://mommy007.com/questions/when-is-the-second-trimester-scan-taken/. I detected that your theme put function flush_rewrite_rules() in init action of wordpress ( you can see it at line 126 in wp-content/themes/classifier/includes/theme-custom-type.php ) that is not safe for URL rewrite feature of WordPress site.

Important: Rewrite rules must be flushed on activation or deactivation to avoid unnecessary rewrite rule flushing.

If you update your theme, please check and remove line 126 in wp-content/themes/classifier/includes/theme-custom-type.php 
Regards 

Sowmini S K
replied 6 years ago

A million thanks to you BigHug! and yeah a big hug too 🙂 you have fixed this intriguing problem that i had with the permalink setting… and relieved a big burden off my shoulders!!
Appreciate your support! Thanks again 🙂

BigHug
replied 6 years ago

you are welcome 🙂

Manuel Cama
answered 5 years ago
DominicStaff
answered 5 years ago

Apologies for the delay in replying to you, the bug comes from the plugin. We are checking and will fix this bug in the next version of the plugin. Please stay tuned and will let you know once done.
Regards,

sreekanth t
answered 4 years ago

Hi i’m getting the same error, after changing the permalinks laso 404 error is coming. Please check and revert

Ishan Sharma
answered 4 years ago

i am having the same issue but something different.
my all dwqa categories and tags are going to page not found.

Category sample – http://solutions.getwpfixed.com/question/category/themes-and-templates/

i have changed the permalink structure also but still getting the same error of page not found.

please solve my issue.
thanks

dominic Staff
replied 4 years ago

We have checked DW Q&A plugin. Sorry to tell you that is some bug from our plugin. We are checking and fix it for a new update. We will release as soon as possible. Sorry about that, my friend.
Regards,

Sundus Alkhraisha
answered 11 months ago

I’ve this issue Error 404: Page not found with DW Q&A Plugin

how i can solve it

Dominic Staff
replied 11 months ago

Please create a private question then send me username & password of the question, and we will check and help you resolve it.

Sundus Alkhraisha
replied 11 months ago

I’ve created private question and it show that ‘Your question is waiting moderator.’ ,same current title .

I’ve this issue Error 404: Page not found with DW Q&A Plugin

Dominic Staff
replied 11 months ago

After submitting the question, your question won’t show. The question will be we check and approve from the Dashboard.
I will check it now.

Powered by DW Question & Answer Pro