Mike
asked 7 years ago

How could I disable to click on an image post and open the post page for the image?
I just want to be able to click on “FullScreen” , as in the demo,  but not to get into the image page when you click on the middle of the image.
That’s the way I like it: http://i.imgur.com/P8zAXSP.png
That’s what I want to disable: http://i.imgur.com/CzcfG09.png
Thank you very much!
Your themes are amazing!

Mike Michelo
replied 6 years ago

Dashboard>Posts>Edit post> in the post, select the image, then click on delete link button or edit the link pointing to the adress you want.
Sorry my bad english.

2 Answers
DominicStaff
answered 7 years ago

Hello Mike !
To resolve the issue of Image popup in the Wallpress:
 You can add images for a post in the Feature Image panel:  log in to Dashboard > Posts > Add New > in the Format pane on the right hand side, select the Image.
See the Screenshot:   Also, You need to add the Jigoshop plugin. You can find the plugin here: http://wordpress.org/plugins/jigoshop/
  Hope this helps!

Mike
replied 7 years ago

Thanks for the quick reply.
I did what you say but it is still the same. If I add a new post and I select image as a format, once I publish it, you can click on the image and it opens as a new post (same format as a normal post http://i.imgur.com/CzcfG09.png). And that is what I want to disable. I don’t want people to be able to click on the image or if they do just to show the fullscreen mode never the normal image post.
Thank you very much again!

Wilfred
answered 7 years ago

Hi Mike
To disable clicking on an image post and open the post page for the image please follow my instruction here:
– Open file content.php in Your site > wp-content > themes > your theme > content.php
– Replace following code – line 12 

<a href="<?php the_permalink(); ?>" title="<?php printf( esc_attr__( 'Permalink to %s', 'dw-wallpress' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark">

by

<?php if( ! has_post_format('image')) : ?>
<a href="<?php the_permalink(); ?>" title="<?php printf( esc_attr__( 'Permalink to %s', 'dw-wallpress' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark">
<?php endif; ?>

– Replace following code – line 21

</a>

by 

<?php if( ! has_post_format('image')) : ?>
</a>
<?php endif; ?>

Hope this works!

Powered by DW Question & Answer Pro