phil fisch
asked 8 years ago

Hi,
I like to hide the category and author that show up after a post above it: By author in category
Is there only a general way to disable both for the whole page or even a possibility to control this on a per post basis (some posts have author and category, some posts only have author, some posts show nothing)?
 
Thank you very much 
Phil

3 Answers
DominicStaff
answered 8 years ago

To hide the category and author in posts, below is our instruction:
Firstly, follow the jetpack’s guideline in the Blog article on how to use Edit CSS here. http://designwall.com/blog/using-jetpack-custom-css-for-your-wordpress-site/
Then add the code to the Edit Css.

.item-author, .item-category {    display: none; }
phil fisch
replied 8 years ago

Thank you very much Dominic, worked perfectly!

However, is there also a way to do this on a per-post basis so that I have some posts with the category and some without?

Thanks
Phil

Dominic Staff
replied 8 years ago

At the moment, DW WallPress does not support this issue.

Elgun Karimov
answered 8 years ago

Hello Dominic,
 
That does not work in my case. I added all he codes but it has no effect. http://awesomescreenshot.com/0183thdl44
 
They are still there. I want to remove both author and detailed questions. Looking forward to hearing from you

DominicStaff
answered 8 years ago

Hi Elgun,
If you want to disable the answer form, you can change permission in the Dashboard > Q&A > Settings > Permission.
About the Author box in your site, I think you have used a plugin. Please send me your site, I will help you remove it from your site.
Regards,

Elgun Karimov
replied 8 years ago

Hi Dominic,Thanks for quick reply. Here is my website: http://www.celt.az and link for QA is http://www.celt.az/dwqa-questions/

Dominic Staff
replied 8 years ago

You can add the following code to the style.css file:
.single-dwqa-question .entry-author { display: none; }
.single-dwqa-question .post-meta { display: none; }
/**** Answer form **/
.dwqa-single-question #dwqa-answers { display: none; }
Hope this helps !

Powered by DW Question & Answer Pro