philippe viondury
asked 7 years ago

Hi everyone,

sorry for the disturbance, but i’ve read and followed the tutorial to translate my DW Timeline wordpress (http://vrbatim.fr) and still have some trouble. Basically, i’ve made the po and mo files, uploaded it in the folder ( for the theme name i’ve picked "twentyfifteen", but i had the choice with fourteen and thirteen… anyway). But when it comes to the modification of the wp-config.php file to redirect, i can’t find, neither in "wp-config" or "wp-config-sample", the code line " define (‘WPLANG’, ”);".

It’s just nowhere…. i don’t understand.

Byt the way, now i’m here, i’d also liked to have my links into the body text (and just there) in red. How should i do?

Best regards, and congrats for the beautiful theme again,
Phil

2 Answers
DominicStaff
answered 7 years ago

Hi,
Please try re-install WordPress, if you still face there issue, you can send me your FTP (via private answer) for further checking.
To change the link color in the body text, you can add the following code to the style.css file:
.entry-content a { color: red; }
Hope this helps !

DominicStaff
answered 7 years ago

Hi,
Right now, you can check the wp-config.php file, I have helped you edit this file.
Also, to remove the post format above the posts, you can add the following code to the style.css file:
.hentry .entry-format {display: none; }
Regards,

dominic Staff
replied 7 years ago

Note: You can add the following code to the wp-config.php file (Under line 64: $tableprefix = ‘vrbatim’; )

/**
WordPress Localized Language, defaults to English.
Change this to localize WordPress. A corresponding MO file for the chosen
language must be installed to wp-content/languages. For example, install
de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
language support.
*/
define('WPLANG', '');
philippe
replied 7 years ago

I lust have some kind of bug… I took the "default" po file in DWTimeline theme folder, translated it with the editor, then saved it (fr_FR.po + mo file) into this folder, upload it with Filezilla in the same folder online, then put the code you gave me in wp-config.php (i even tried to put it in wp-config-sample as well), but it still doesn’t work… Unbelievable… (thanks for the css though, it worked perfectly).

I really don’t get it… tried everything, even to do it again, reload the files and so on….

dominic Staff
replied 7 years ago

In WordPress 4.1 does not exist wplang at wp-config.php. Just go to Settings > General > Site language, and change language
Right now, you can tell me detail about the position that you want to change the language. I think you need to change in the .php file.
Regards,

philippe
replied 7 years ago

Hi Dominic. First thing i did was to put the site language in French :/
I just need to change (the very priority) the "continue reading" at the bottom of the posts on the home page in "Lire la suite". And also, if possible (but less worrying) the "by" by "par, the "on" by "le" and the "in" by "dans"…
Best Regards,
Phil

dominic Staff
replied 7 years ago
  • "continue reading"
    Open the content.php file in the folder path "wp-contentthemesdw-timelinetemplates". Find line 14.
  • "by/ on/ in"
    Open the entry-meta.php file in the folder path "wp-contentthemesdw-timelinetemplates".Find the line 5/ 9 /11.
    Hope this helps !
philippe
replied 7 years ago

Thank you very much. It worked perfectly. No more questions 😉
Best,
Phil

Powered by DW Question & Answer Pro