Nifemi Aluko
asked 5 years ago

This is a great plugin. I followed the instructions to include a drop-down that allows me to filter Q&A based on tags. I have included the drop down menu, but whenever I choose a tag, it redirects my to a blank page. For instance, if the tag chosen is "business" the site address is redirected from

http://kpakpakpadev.wpengine.com/answers/question-tag/business/

to

http://kpakpakpadev.wpengine.com/answers/

My website is http://kpakpakpadev.wpengine.com

Thanks

2 Answers
DominicStaff
answered 5 years ago

I need to debug directly on your site, please PM me url, admin of your site.
Regards,

Allen
answered 5 years ago

@Nifemi Aluko: hi , i think your tag filter work fine , but some how the category and tag page is wrong. As i turn off the visual composer , the redirect will be gone , but the the url there point to a wrong page like these:

  1. Answer Page when go to answer and use filter : ![enter image description here](http://i.imgur.com/LoqC7HG.png?1 "enter image title here")

  2. Answer Page when you paste the direct url : ![enter image description here](http://i.imgur.com/tnJq62v.png?1 "enter image title here")

It’s kinda different page ( maybe it happen by the template of the theme ).
First thing to do, please , i need you to re-install dwqa, dont make any change and test that category page exist or not ( Just to test the plugin work find before you add new filter function ). And after that , you add tag filter again. Glad. If it’s the problem by the filter i’ll check it carefully ( because at this moment , i can’t remove the plugin and re-install again for you ).Thanks for your cooperate.

Powered by DW Question & Answer Pro