Sylvain Borgarino
asked 5 years ago

Hello!
 
I have a problem when I try ti insert gallery or images in a post. Thumbnails in the library viewer don’t load (it stays blank).
What can I do ? Please help me!!!!
 
Thank you !
 
 
 

5 Answers
DominicStaff
answered 5 years ago

Hi,
Firstly, please deactivate  all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one and let us know if you find the problematic plugin(s). Maybe there is a conflict in plugins.
If you still face there issue, you can send me username & password of your site for further checking (via private answer).
Hope this helps !

Sylvain Borgarino
replied 5 years ago

Thank you for the quick answer !I tried to desactivate all pluggins but nothing changed 🙁 Gallery is still loading without images…

Sylvain Borgarino
answered 5 years ago

If I try to desactivate the theme and re-activate it, will all my custom features will be erased ? (custom CSS etc..) DO you think this could help ?

DominicStaff
answered 5 years ago

If this does not fix your WordPress library follow this list of solutions that I have developed!
Step 1: Log into your admin panel.
Step 2: Go to Settings > Media
Step 3: In the first writable field (Store uploads in this folder) it will state that the Default is wp-content/uploads but, it will not register this as “True”.
Step 4: Type “wp-content/uploads” within the field. (Also, make sure that “Full URL path to files” is blank.)
Step 5: Click, Save Changes. Now test to see if your Media Library is now functioning if not go to the next steps:
Step 6: Open up your File Transfer Protocol or (FTP).
Step 7: Go to your wp-content section. This will be listed within your sever at YOUR-SITE.COM/wp-content/
Step 8: Right click or highlight your “uploads” folder. If you do not have one then create one and test to see if your Media Library is now functioning. You need to have a folder here at YOUR-SITE.COM/wp-content/uploads/
Step 9: If you have an uploads folder already, select its “File Permissions”.
Step 10: Set the Numeric Value to 755 or 777 (777 can present a security risk see details below). Now test to see if your Media Library is now functioning if not go to the next steps:
Step 11: Go back into WordPress.
Step 12: Go back into Go to Settings > Media
Step 13: Uncheck “Organize my uploads into month- and year-based folders”.
Step 14: Click, Save Changes. Now test to see if your Media Library is now functioning if not go to the next steps:
Step 15: If your Media Library is still not working there is only one more step that I can fathom. Go back into your File Transfer Protocol or (FTP).
Step 16: Right click or highlight your “wp-content” folder.
Step 17: Select “File Permissions”.
Step 18: Set the Numeric Value to 777. Now test to see if your Media Library is now functioning and hopefully it is by now. Please note if your website is still down, it could potentially one of two things. The first being a plugin that you chose or created. Most free plugins do not take in consideration that your site matters. It is a pain, but do some research on the person who uploaded the theme and be sure that you check their reviews. The second reason could be due to some of your folder permissions — they might have been lost during a host transfer.
Step 19: If these solutions don’t work double check your .htaccess file and make sure this file matches with the theme you have installed on your site. Sometimes if this is not setup correctly it will re-write the path of the uploaded image. This is something you will have to investigate on your own and you can click here to fix your WordPress htaccess file.
Try re-installing WordPress again, and re-importing your themes and plugins. If these solutions still do not work, feel free to contact us and we will try to help.

Regards,

Sylvain Borgarino
answered 5 years ago

wow! thank you for the answer!
Step 1: OK
Step 2: OK
Step 3: I have no writable field here, only fields for thumbnails and images size (only writable with pixel numbers)
Step 4: Don’t know where to put this 🙁
Step 5: Nothing happens, as I didn’t modify anything..
Step 6 to 10: /wp-content/uploads/ folder already existed, I wend into the file permissions and set the numeric value to both number and click the “apply” button. But nothing changed for the 2 values.
Step 11 to 14: I tried to check and uncheck “Organize my uploads into month- and year-based folders”. Nothing changed.
Next steps: not try yet.
Could you help me for step 3?
Thank you so much for your time! And sorry if I don’t understand everything, I am a “basic” user of wordpress.

DominicStaff
answered 5 years ago

I have checked your site and this issue does not from our theme. I think it come from wordpress. Have you tried:
resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
– re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.
Note: 
Could you please try using the solutions posted on the following pages to resolve this issue?
http://www.wpbeginner.com/wp-tutorials/how-to-fix-image-upload-issue-in-wordpress/
http://www.htpcbeginner.com/how-to-fix-wordpress-http-error-while-uploading-media/
http://www.bappi-d-great.com/http-error-when-uploading-images-in-wordpress-no-thumbnail/
http://wordpress.stackexchange.com/a/59777

Hope this helps !

Sylvain Borgarino
replied 5 years ago

Hello Dominic, thank you for your answers.I’ve been working on this issue the past 2 days and I have to admit I am completly lost…I’ve tried almost everything I am able to do (according to my low understanding), nothing seems to fix the problem. I don’t know what to do anymore…I saw on forums a lot a people is have the same problem, but nobody have the solution :(They are talking about .htaccess file, phpMyadmin, MySQL database etc… Things I don’t know and don’t understand…I have no idea how to proceed to solve this issue. Last thing i could do is to reupload all files from a new WP download. I’m affraid I could lost my content as I have no backup yet (as I said I’m traveling, and I’m actually in Thailand, and internet is not good enough to backup everything from the ftp without having a crash). Do you think I can erase everything -but – the wp-content folder and it will work? I will keep all the data?Thank you again for your help.Sylvain

Sylvain Borgarino
answered 5 years ago

People talks about modify the .htaccess file in the root of the wp folder, in the ftp.
Here: http://www.bappi-d-great.com/http-error-when-uploading-images-in-wordpress-no-thumbnail/
or here: http://wordpress.stackexchange.com/questions/59763/how-to-fix-http-error-when-uploading-images/59777#59777
 
When I try to create the file (with textedit), to upload it on the ftp, and then to change it’s name to “.htaccess” in order to overwrite the older, it never works. I have a 500 internal server error immediatly after that on the blog.
So I overwrite the file again with this lines only and everything comes back normal, exept my library problem of course (someone from OVH gave me those lines a few month ago to solve a problem I had:

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress
 
Do you know how should I modify the file to work properly as shown by the exemples below ?

Dominic Staff
replied 5 years ago

Please send me your FTP for further checking.

Sylvain Borgarino
answered 5 years ago

Hello Dominic,
 
I would like to thank you for your help.
I finally re install WP 4.0 and then update it to the last version and everything seems to works correctly again.
Hope it will last!!
 
Regards,
Sylvain

Dominic Staff
replied 5 years ago

Awesome ! If you have any question, please create a new question, we will help you resolve it 🙂

Powered by DW Question & Answer Pro