Oren Margalit
asked 3 years ago
  1. i have hidden the comment box following the question part (so you can only comment on the answers). but the problem is that in the mobile view the comment box still appears, and only in the pc version it is hidden. how can i hide it also in the mobile view?
  2. how can i hide the voting counts and arrows from the site?
  3. Whenever someone inputs a new question from mobile, the title in hebrew is shown as a strange code like this:%D7%A2%D7%9C-%D7%AA%D7%95%D7%A4%D7%A2%D7%AA-%D7%94%D7%99%D7%A6%D7%99%D7%90%D7%94-%D7%91%D7%A9%D7%90%D7%9C%D7%94-%D7%98%D7%95%D7%A8-36/
    how can i fix this?

 
you have answered:
1 & 2: Please add the following code to the style.css file: 

.single-dwqa-question .dwqa-question-item .dwqa-question-vote, .single-dwqa-question .dwqa-answer-item .dwqa-answer-vote {
display: none;
}
.single-dwqa-question .dwqa-question-item .dwqa-comment-form {
display: none;
}

3/ Please send me your site URL for further checking.
 
and this is my response:
 
regarding 1 and 2:
1. i have inserted the code you gave me and the problem still persists in the mobile view. the comment box on the question part is still shown.
2. the code you gave me has succeeded in hiding the arrows for voting. but the vote counters still show in the main page of the Q&A. how can i hide them?
3. http://www.mikyab.net

2 Answers
DominicStaff
answered 3 years ago

To remove the vote count in the main question page and the comment section, you can add the following code to the style.css file:

span.dwqa-votes-count {
   display: none;
}
.single-dwqa-question .dwqa-comment {
display: none;
}
Dominic Staff
replied 3 years ago

Also, you can disable the plugins to check the issues. If you still face their issue, please send me username & password of your site for further checking.

Oren Margalit
replied 3 years ago

i have tried inserting the code above and it didn’t help at all (the problems above still persist).

i want to emphasize that only in the desktop view, the comment box in the question part is hidden. but in the mobile view it is shown. this is the most important problem for now.

is there any code i can add that deals with the mobile view problem?

Dominic Staff
replied 3 years ago

Please send me username & password of your site for further checking. I have checked on our demo with the my code and it works fine.

Oren Margalit
replied 3 years ago

how can i send it privately?

Dominic Staff
replied 3 years ago

You can use the private answer: http://prntscr.com/dgarfx

DominicStaff
answered 3 years ago

I have helped you resolve this issue, please check your site now.

Oren Margalit
replied 3 years ago

thank you.
the voting counts were indeed removed. is it possible to also remove the “sort by votes” option?

also, the problem regarding the comment box in the question section in mobile view is still showing. can you help me hide it in mobile view? (the comment box in the question section, not the answer section).

Dominic Staff
replied 3 years ago

To remove the sort by votes, you can add the following code to the custom CSS:
.dwqa-sort-by { display: none;}
About the comment box, I have checked and see that it removed, you can send me a screenshot for further checking.

Oren Margalit
replied 3 years ago

regarding the sorting, i want to keep the sort by views and sort by answers, but hide the sort by votes. is that possible?

Dominic Staff
replied 3 years ago

I have checked and I see that it’s cache site, please clear cache your site and check it, If you want to remove the vote in the Sortby section, you can open the archive-question-filter.php file and remove the line 35.

Oren Margalit
replied 3 years ago

the cache is off in my site (and was off for a long time). is there another way to fix this issue?

Dominic Staff
replied 3 years ago

You can create a dwqa-templates folder in your theme folder and copy/paste the comments.php file from DW Q&A plugin to this folder and remove the following code:
<pre><div class="dwqa-comments">
<?php do_action( 'dwqa_before_comments' ) ?>
<div class="dwqa-comments-list">
<?php do_action( 'dwqa_before_comments_list' ); ?>
<?php if ( have_comments() ) : ?>
<?php wp_list_comments( array( 'callback' => 'dwqa_question_comment_callback' ) ); ?>
<?php endif; ?>
<?php do_action( 'dqwa_after_comments_list' ); ?>
</div>
<?php if ( ! dwqa_is_closed( get_the_ID() ) && dwqa_current_user_can( 'post_comment' ) ) : ?>
<?php
$args = array(
'id_form' => 'comment_form_' . get_the_ID(),
);
?>
<?php dwqa_comment_form( $args ); ?>
<?php endif; ?>
<?php do_action( 'dwqa_after_comments' ); ?>
</div></pre>

Oren Margalit
replied 3 years ago

can you explain a bit more on how to do this step:

1. what is the location of the theme folder?
2. what is the location of the comments.php file

Oren Margalit
replied 3 years ago

suddenly i have a problem that the comments don’t appear at all in desktop view (not in the question section, and not in the answer section). is there anyway to fix this also?

Dominic Staff
replied 3 years ago

Go to your theme folder (wp-content/themes/[theme-name]), and create a new folder, named it “dwqa-templates”. Inside your new folder, create a new file: “comments.php” and paste the following code to the comments.php file:

<?php
/**
* The template for displaying comments form
*
* @package DW Question & Answer
* @since DW Question & Answer 1.4.3
*/
?>

<?php if ( comments_open() ) : ?>
<div class="dwqa-comments demo-comment">

</div>
<?php endif; ?>

Powered by DW Question & Answer Pro