yymailb
asked 1 week ago

I’ve installed Q&A Pro latest version, and enabled upload file. There are some problems.
1. I can’t download the file uploaded. when I click the attachment file icon (URL= https://www.shinnytech.com/question/qtest/attachment/3137/), browser just keep 301 redirecting me to the same url. then the browser prompt “ERR_TOO_MANY_REDIRECTS”
2. Q&A Pro don’t show the uploaded file’s filename. so, if somebody upload multiple files in one question or one answer, the others has no way to identify them seperately.
3. The attachment file icon is very hard to click. Mouse cursor must point the edge of the icon accurately to make the cursor became a hand. 

Dominic Staff
replied 1 week ago

Please send me username & password of your site for further checking, I have checked on our demo and the feature still work fine.

yymailb
replied 6 days ago

I’ve tried this on your demo site(http://demo.designwall.com/dwqa/ask-question/) and failed. I tried to post a question with these fields:

* Title: upload file test
* Your Email: xxxxxx@gmail.com
* Your Name: yymailb
* File: a txt file, which content is 1 char: “1”, filename is “1.txt”

When I clicked the “Submit” button, I got some warning message:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘dwqa_attachment_handle_upload_error’ not found or invalid function name in /data/www/demo.designwall.com/public_html/wp-admin/includes/file.php on line 352

Warning: Cannot modify header information – headers already sent by (output started at /data/www/demo.designwall.com/public_html/wp-admin/includes/file.php:352) in /data/www/demo.designwall.com/public_html/wp-includes/pluggable.php on line 1195

Dominic Staff
replied 3 days ago

We have checked this issue and think that your server does not allow upload the .txt file.
In this case, you can add the following code to the functions.php file.

function my_custom_mime_types( $mimes ) {
// New allowed mime types.
$mimes[‘txt’] = ‘text/plain’;
return $mimes;
}
add_filter( ‘upload_mimes’, ‘my_custom_mime_types’ )

1 Answers
DominicStaff
answered 1 week ago

I sent and notified to our technical team about this issue, we will check this issue now.

Powered by DW Question & Answer Pro