Eric Tischler
asked 7 years ago

I have been having layout problems with the category grid view in that the text that shows is often cut off by the bottom of the box it is in within the top grid setup, instead of there being just a small bit of text followed by tags. This was solved by setting up an actual excerpt that is short enough, but I just ran into another problem.

One of the posts I have has a portrait-oriented image and this post is showing in the larger box in the category grid. The problem is that the image is being forced to full width within that cell, which pushes all the text and most of the image out of view below the bottom of the cell in the grid. I got it out of that position by changing the post date so a post with a landscape image was “newest”, but now that portrait image is in one of the other cells and it still pushes all the text down out of view.

I doubt that this can be fixed, so I want to know how I can prevent the grid view from being used. I want the list view to be default and no way to select the grid view.

I also notice that sticky posts to not rise to the top of a category page. Is there a way to do that?

Thanks

 

3 Answers
Eric Tischler
answered 7 years ago

Well, just found the settings to make the list view default. I will use css to hide the grid view button. Too bad the grid view only works for landscape-oriented images.

Eric Tischler
answered 7 years ago

Well, just found the settings to make the list view default. I will use css to hide the grid view button. Too bad the grid view only works for landscape-oriented images.

DominicStaff
answered 7 years ago

To resolve this problem you can log in to Dashboard > Theme > Customize > Category Settings > to make the list view default. And then add the the following code to the General Settings > Header Script.


<style>
.layout-grid {
display: none !important;
}
</style>

Regards,
Dominic

 

Powered by DW Question & Answer Pro