Philip Trauring
asked 3 weeks ago

I’m getting error messages at the top of the page since I updated Timeline Pro recently, both on the front end and the back end. Also, the the Themes page it says there’s an update available (1.1.1) but if I try to update it fails. If I download the update from the DW web site and upload it manually, it still says that there’s an update available. The error message is:
Warning: Declaration of description_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /path/wp-content/themes/dw-timeline-pro/functions.php on line 69 Warning: session_start(): Cannot send session cookie – headers already sent by (output started at /path/wp-content/themes/dw-timeline-pro/functions.php:69) in /path/wp-content/themes/dw-timeline-pro/framework/includes/hooks.php on line 256 Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /path/wp-content/themes/dw-timeline-pro/functions.php:69) in /path/wp-content/themes/dw-timeline-pro/framework/includes/hooks.php on line 256
I’ve replaced the full path with the word ‘path’…

2 Answers
DominicStaff
answered 3 weeks ago

Please send me username & password of your site for further checking.

Philip Trauring
replied 3 weeks ago

I can’t send you the login credentials. Do you have any suggestions as to what is happening?

Philip Trauring
replied 3 weeks ago

I checked the version installed and it was 1.1.1. I then went again to the Theme update page and tried to update it, and it actually said you have 1.1.1 and you need to update to 1.1.1. I tried it and now it finished the ‘update’. Now the message I see is:

Warning: session_start(): Cannot send session cookie – headers already sent by (output started at /path/wp-content/themes/dw-timeline-pro/lib/custom.php:2) in /path/wp-content/themes/dw-timeline-pro/framework/includes/hooks.php on line 256 Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /path/wp-content/themes/dw-timeline-pro/lib/custom.php:2) in /path/wp-content/themes/dw-timeline-pro/framework/includes/hooks.php on line 256

Dominic Staff
replied 3 weeks ago

I have checked on our demo and the theme still works fine. I have uploaded a new package. Please download from your profile and upload it into your site now.
If you still face their issue, I need to access your site for further checking.

Dominic Staff
replied 3 weeks ago

I have checked on our demo and the theme still works fine. I have uploaded a new package. Please download from your profile and upload it into your site now.
If you still face their issue, I need to access your site for further checking.

Philip Trauring
replied 3 weeks ago

That seems to have fixed it, thank you.

Dominic Staff
replied 3 weeks ago

Yes, Thank for your feedback. Let me know if you have any issue or question.

Philip Trauring
answered 3 weeks ago

I’ve run into another problem. I went to the Widgets page and got the following message at the top:
Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_search() expects parameter 2 to be array, null given in /path/wp-includes/widgets.php on line 1378 Warning: array_merge(): Argument #3 is not an array in /path/wp-includes/widgets.php on line 1211 Warning: array_diff(): Argument #2 is not an array in /pathwp-includes/widgets.php on line 1212 Warning: Invalid argument supplied for foreach() in /path/wp-includes/widgets.php on line 1214 Warning: array_merge(): Argument #1 is not an array in /path/wp-includes/widgets.php on line 1222
Any ideas?

Dominic Staff
replied 3 weeks ago

I think this is a conflict the plugins, you should try to disable the plugin to check this issue.

Philip Trauring
replied 2 weeks ago

It also always shows that it needs an update (1.1.1 to 1.1.1) and if you run the update it still shows it there.

Dominic Staff
replied 1 week ago

Very hard to check this issue and find a solution for you. I have checked on our demo and localhost and see that the theme still work fine. If you disabled all the plugins and still face their issue, you can send a back-up site for further checking.

Powered by DW Question & Answer Pro