iolit
asked 7 years ago

Gallery format not working on front page with Infinite scroll

I’m using Wallpress theme (free). I really love this theme, but I’m wondering if there’s something I can do about Gallery format not working on front page…  When I’m clicking on the “next” or “prev” icons, nothing happens, there’s only one image showing.

My front page/index.php shows latest blog posts, and my settings are to show maximum 9 blog posts, and when the user scrolls the infinite scroll do the rest and load next set/page. But the gallery-format only works on my first set (page) of posts… I changed the reading settings to show maximum 50 posts, and the gallery format works fine on my latest 50 posts  (you can see all images in the gallery from the front page)…

Is there anything I can do to make gallery format work, when posts are loaded/called by the infinite scroll?

My website: filter.pm (under construction).  Tnxxx alot for any help! (Sorry for bad English, hope it’s possible to understand my quetsion…)

3 Answers
DominicStaff
answered 7 years ago

Hi !

–  If would you like new post shown stylesheet “format-gallery”, when you create a new post you select format > gallery.

See the Screenshot:

 

iolit
answered 7 years ago

Hi Dominic, thank you for your answer!

I have selected the  gallery post format! So that is not my problem.

My problem is that my reading settings for wordpress is to show maximum 9 of my latest posts on a page. I don’t want it to be higher/more posts,  for example 100 latest posts, because it really slows down the loading time /performance of my site, to load so many posts at one time. Therefore my settings are to show maximum 9.

When the user scrolls, the infinite scroll makes sure that next page is loaded – the next 9 posts, and so on.  And every post I have created with gallery-format selected, that are called by infinite scroll / older than my 9 latest posts, doesn’t work on the front page. I cannot slide to the next or previous image.

If I change my reading settings to show my latest 50 posts, it works again (I can watch the full gallery/all images from the front page).

On my webpage , there are a post with title “Pick a Pony” (I haven’t published so many posts yet). If you try to watch the gallery, you will se that it doesn’t work. My third post though, “Venice pt. 2”, works perfectly.

 

Is there a solution? Thank you!

DominicStaff
answered 7 years ago

Hi !

Our theme is designed defaultly like that. So we can not support you as your requirement. You can customize anything you want in the Dashboard > setting > reading only.

Regards,

Dominic

Powered by DW Question & Answer Pro