Daniel Laursen
asked 5 years ago

Hey there!   I just recently made more space on the “post” pages by removing the sharing and author buttons by adding this code to the CSS:

.single .site-content>.hentry .entry-action {
display: none;
} .archive .content-inner.layout-grid .hentry.first:before {
width: 700px;
} .single .site-content > .hentry .entry-content {
width: 700px;
max-width: 700px;
}

The main issue is that whenever I view a post on mobile, the content is wide and it’s impossible to see the entire article. It simply cuts off some of the article, even though it looks great on a PC.   

How do I make the post page responsive again?

Manya Koetse
replied 5 years ago

You have the same problem I had yesterday, check out the thread: http://cmspioneer.com/designwall/question/need-help-asap-my-articles-are-not-responsive/

Daniel Laursen
replied 5 years ago

Hey there. Well, not exactly the same. I tried doing what they told you, but it seems that you would like the sharing buttons to still be there. I want NOTHING in the left-side, as I need the space for the content itself.

Have you found a way to do that? While still remaining responsive on mobile?

Daniel Laursen
replied 5 years ago

Another update: I found out that if I just removed everything in the .css, and replaced it with this (from your thread):
.single .site-content>.hentry .entry-action {
display: none;
}
@media (min-width:980px) {
.single .site-content > .hentry .entry-content {
width: 100%;
max-width: 100%;
}
}
@media (max-width:767px) {
.single .site-content>.hentry .post-categories {
float: none;
}
}

It actually worked! Thanks a lot 🙂

Manya Koetse
replied 5 years ago

Exactly! That’s the instructions I was given, which removes everything, but then I wanted to leave the sharing option. Welcome 🙂

Powered by DW Question & Answer Pro