r c
asked 5 years ago

Hello,

So I’ve been trying to use custom permalinks so that it’s just the post name that shows up. I contacted my host and they added the web.config file which helped the situation as now the pretty permalinks work for individual posts/page. However, whenever I try to go back to the homepage or use the main domain, I get a 404 again.

My host (godaddy) informed me this is a problem with the theme.

pradipv156
replied 5 years ago

If you are used WP then you will try "/%category%/%postname%/%post_id%"

5 Answers
DominicStaff
answered 5 years ago

Hi,
Please send me username & password of your site (via private answer) for further checking.
Regards,

john pate
answered 5 years ago

try this code for permalinks. " /Êtegory%/%postname%/%post_id% "

coolstorybro
replied 5 years ago

unfortunately this just creates the same problem of permalinks working but the main domain getting a 404

dominic Staff
replied 5 years ago

Hi,
At the moment, can’t Access WordPress Admin After Changing URL. Here is the Fix.
the solution is simple, all you have to do is to add the following code at the end of your ”wp-config.php” file.

define('WP_HOME','http://radiyahchowdhury.com/');
define('WP_SITEURL','http://radiyahchowdhury.com/');

Sorry about that.
You can send me your FTP, I will help you resolve it.
Regards,

pinaloza
replied 5 years ago

you have problem in your .htaccess so you will add code into your file as below.

 # BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

and try it.

Regards

Priya Javia
answered 5 years ago

regarding my problem – i did changes to kses.php, rewrite.php and then .htaccess.. I have reset all of them, but still same problem. Pages work, category page shows the post, home page shows the posts, but single post in atahualpa won’t show. I tried the classic theme, deactivate all the plugins, won’t work. If I put default option for permalinks /?p=123, it works. Pretty permalinks wont work at all. Funny thing is it works for pages all the time. I have multiple WP in one machine, where ever I tried to make those changes last week, they are all broke, it was working for the past 1 year. Any help would be appreciated.

Aish Kapoor
answered 5 years ago

Recently I have develop site I had same problem in it when i am trying to use Pretty Permalinks but i didnt get 404 error or any other error when i was using default structure of permalinks so please suggest me proper Secure solution to short out this problem…i wan to set structure of my permalinks as follow website-name/Category/Name-of-Post currently i am using WordPress 4.0 and Thesis_185 and i have installed few plugin so suggest me any effective solution if any one found through my GMail id aishkapoor9896 or you can leave it replay here Thanks to All

dominic Staff
replied 5 years ago
Vaishnav pradip
answered 5 years ago

If you are used WP then you will try "/Êtegory%/%postname%/%post_id%"

Vaishnav pradip
answered 5 years ago

If you are used WP then you will try "/Êtegory%/%postname%/%post_id%"

I am already check on my website so you will try and change the pera link on your web portal.

Robert Tincal
answered 5 years ago

Thank you Pradip, I am used this tips on my wordpress website and its works.

Akshat Verma
answered 5 years ago

clear your wordpress cache and then deactivate and reactivate the plugin again. i have used it on my site

sudhakar _
answered 5 years ago

Thanks for asking your Question. For Latest Job Updates visit

Akshat Verma
answered 5 years ago

Clear your wordpress cache, that http rewrite rules are written in .htaccess and then try again.

Powered by DW Question & Answer Pro