Dirkjan van Ittersum
asked 11 years ago

I have made a dutch .po and .mo file for the plugin. The files are in the folder /dw-question-answer/languages/. How do I activate it? Thank you.

5 Answers
DominicStaff
answered 11 years ago

Hi Dirkjan, 
We have released the updated version 1.0.2 for DW Question & Answer plugin, please download and update the plugin to latest version.
In this version, we have included the Translation function, now the plugin is ready to translate into any language. The user guide is on the way. 
Here is the quick instruction:
Firstly, make sure that you saved  your .po file and .mo file according to your language code (You can find your language code at http://codex.wordpress.org/WordPress_in_Your_Language#Dutch_-_Nederlands_.28nl_NL.29 ).
Then you need to add prefix “dwqa-” to your translation file name (to both .po file and .mo file).
So, you would have two separate files as dwqa-nl_NL.po and dwqa-nl_NL.mo

Secondly, go to the wp-config.php file, find the code below:

 define ('WPLANG', '');

And change it to:

 
define ('WPLANG', 'nl_NL');

Save your wp-config.php file, and you are ready to go.
Please try and let me know the result.
Cheers!

Dirkjan van Ittersum
replied 11 years ago

Hi Dominic,

The update works like a charm, thank you!

Hiroaki Kobayashi
answered 10 years ago

I have same question too.
In my case, I want to use dwqa in Japanese.
I tried to rewrite po, mo file in Japanese, but  It is same as before.
(My theme is x2 for BuddyPress theme)
What is wrong?
Please teach me.
 

DominicStaff
answered 10 years ago

Hi Hiroaki, Firstly, I think you will need to take a look at the following instruction on how to translate the DW Q&A plugin http://www.designwall.com/guide/dw-question-answer-plugin/#how_to_translate_dw_question_answer_plugin If you still get stuck with those, let us know. Hope that helps !

pavel hodosevich
answered 9 years ago

Hello, I created a Hebrew translation of DWQA plugin with Poedit, the file name is: dwqa-he_IL.po and dwqa-he_IL.mo
I also change the code  wp-config.php file from: define (‘WPLANG’, ”);  to: define (‘WPLANG’, ‘he_IL’); and uploaded it to my wordpress site: wp-content/plugins/dw-question-answer/languages.

but when I done all the steps right, nothing is happening, I checked myself several times and I’m sure that I done all right, just as I told here:  http://www.designwall.com/guide/dw-question-answer-plugin/

can I get some help?

DominicStaff
answered 9 years ago

You can send me your dwqa-he_IL.po and dwqa-he_IL.mo file via email: [email protected]. We will check on our demo.
Regards,

pavel hodosevich
replied 9 years ago

Great, thanks for the fast answering, I just sent it.

Jorge Ovalles
answered 8 years ago

Hi, in new version of wordpress the –> define (‘WPLANG’, ”) is obsolete. 
How i can say to wdqa to use others .mo or .po files for language?

DominicStaff
answered 8 years ago

To translate the plugin, you can do the following:

  • Go to the Settings > General settings and change the language of the site into the English language. 
  • Disable the Q&A plugin > Remove all the language file in the language folder and copy/paste your language file into the folder. 
  • Change the language to your language in the General settings. 
  • Finally activate the plugin.

If you still face their issue, you can send me your FTP & username & password of your site, I will check and help you resolve it.

alexey
replied 8 years ago

I have same problem. No changes to Russian language.
Disable/enable, change to eng and back, remove .po .mo files and nothing

WP 4.6.1

DW Question Answer Pro Version 1.0.0

Allen
replied 8 years ago
Powered by DW Question & Answer Pro