bryan alman
asked 5 years ago

I notice that when I filter all answered questions only one question will show even If I have three questions that has already answered.

http://www.postinger.ph/online-forum/

Please help me.

3 Answers
Allen
answered 5 years ago

@bryan : i see that you try to use my code at lastest to fix the problem about answered filter.First i need you to check the database, you can go to phpmyadmin and access to the database. In postmeta table, please search for "_dwqa_status" = "answered", the filter will get all question have that status, so please check how many post_id have metakey like that.
If it’s just 2( like filter in your website right now ) then the query is right , and then you can please change the "_dwqa_status" of answered question to "answered". You can add new question and answer to test it again. If that stranger behavior still occur, please provide me account to your web site, i’ll help you.Glad

bryan alman
answered 5 years ago

The result in my website when I filtered is 2 but in Database I have 4 answered questions.

bryan alman
answered 5 years ago

![enter image description here](http://www.postinger.ph/?attachment_id=18320 "enter image title here")

nobita
replied 5 years ago

@bryan alman , hi , thank you for your information.At this time , it’s hard for me to detect the bug, so , can you send me your site or FTP `via private answer so i can check it for you. Glad 🙂

nobita
replied 5 years ago

@bryan alman :Hi mate, I’m trying to check the site and so sorry to say that it’s our bug with question list filter. Our filter function is kinda mess up and slow. I think we need time to fix and re-config the filter function of dw-question-answer to make working more accurate and faster. Sorry for that inconvenience. Hope you can understand.

Powered by DW Question & Answer Pro