Paul M
asked 8 years ago

When people write long posts, it’s one massive paragraph with a <br> in place of the paragraph. The same happens when we answer.
Is there any way I can fix this?

5 Answers
Paul M
answered 8 years ago

I notice the same happens here. One massive paragraph definitely isn’t ideal for SEO or usability. 

Paul M
replied 8 years ago

Testing a comment.

Does it add paragraphs?

Paul M
replied 8 years ago

I notice when I edit the question in the front end, to add breaks, the paragraphs work successfully. So I can only imagine this is a bug?

Paul M
answered 8 years ago

Hello
Another test

DominicStaff
answered 8 years ago

To resolve this issue, you only possible add the following code to the style.css file:

/* Single question page */
.single-dwqa-question p{
    margin-bottom: -0.9em;
}

Hope this helps !

Paul M
answered 8 years ago

Hi Dominic the editor is actually spitting out no paragraphs. 
 
Line one<br>
Line two<br>
etc
It should be:
<p> Line 1</p>
<p>Line 2</p> 

DominicStaff
answered 8 years ago

At the moment, to resolve this issue, you can press “shift+enter” key.

Paul M
replied 8 years ago

I can’t really tell that to our visitors? I will have to try and find a fix.

But if you can fix this in a future release that’d be great.

Dominic Staff
replied 8 years ago

Sorry about that and also thanks for letting us know. We will discuss about this issue.

Do An Duy
replied 6 years ago

Hi,

Has this issue been resolved as of the lastest version?

DominicStaff
answered 6 years ago

Yes, this issue have fixed in the latest version of the plugin.

Do An Duy
replied 6 years ago

Thanks for your reply, Dominic.

Unfortunately, the issue still exists for me.
You can see this video to see it: https://www.youtube.com/watch?v=JbZ1ZUrzH7c

This doesn’t happen when I write a normal WordPress post.

Can you please look into this for me?

Thank you.

Dominic Staff
replied 6 years ago

I know what you want. I have checked on our demo and see that I have fixed it and if you want to write a paragraph same as you did in the video, you need to use the shift + enter.
Example:
Paragraph 1 " shift + enter"
"shift + enter"
Paragraph 2.

Do An Duy
replied 6 years ago

I see. Thanks.

But as Paul M said above, my visitors are not tech savvy enough to know that. When they ask questions on my site, they think the spaces they see in the editor will stay, but they are actually removed after they post. This can lead to ugly formatting and bad user experience.

I'd like to preserve the tags like when I compose a normal WordPress post.

What can I do?

Dominic Staff
replied 6 years ago

Yes, if you resolve this issue, you can add the following code to the functions.php file of your theme:

/* Filter Tiny MCE Default Settings */
add_filter( ‘tiny_mce_before_init’, ‘my_switch_tinymce_p_br’ );

/**
* Switch Default Behaviour in TinyMCE to use “”
* On Enter instead of “”
*/
function my_switch_tinymce_p_br( $settings ) {
$settings[‘forced_root_block’] = false;
return $settings;
}

Do An Duy
replied 6 years ago

Thanks for you help.

I did as you said but unfortunately it doesn’t work.

Dominic Staff
replied 6 years ago

Please send me username & password of your site via private answer, I will check it.

DominicStaff
answered 6 years ago

@Duy, Please check your site now, I have helped you resolve this issue.

Do An Duy
replied 6 years ago

Yes it has been solved now. It is now exactly what I want.
Thank you very much for your kind support, Dominic.

Dominic Staff
replied 6 years ago

If you have any issue, please let me know, I will help you resolve it, my friend.

Powered by DW Question & Answer Pro