Stefan ddd
asked 7 years ago

I enable reCaptcha and fill keys, but reCaptcha not showing on any page – old or new, nothing. But when I try to post question, “wrong captcha message” on top of page.

3 Answers
DominicStaff
answered 7 years ago

Hi,
Please send me username & password of your site (via private answer) for further checking.
Regards,

Stefan ddd
replied 7 years ago

I can’t send u user and pass, it’s a big website. But I can send you screeshoots. Just say what

Dominic Staff
replied 7 years ago

You can send me your site & a screenshot (Use: http://imgur.com/) for further checking.

Stefan ddd
replied 7 years ago
Dominic Staff
replied 7 years ago

Make sure you have added the Google Captcha Public/ private Key in the settings of DW Q&A plugin (Dashboard > Q&A > Settings).
See the screenshot: http://prntscr.com/641sfn

Stefan ddd
replied 7 years ago

I wrote in the first post that I fill fields.

Dominic Staff
replied 7 years ago

It’s hard to me to fix the problem for you right now. Please grant me to access your site to check exactly what’s happening in your site to help you out as soon as possible.please deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one and let us know if you find the problematic plugin(s). Maybe there is a conflict in plugins.

Stefan ddd
answered 7 years ago

Ok, I know what is problem – SSL. I’am disable SSL for my website and reCaptcha work! Any fix for it? I want SSL and reCaptha.

Stefan ddd
answered 7 years ago

Here is solution:

in /dw-question-answer/inc/lib/recaptcha-php/recaptchalib.php on line 106

change this:

function recaptcha_get_html ($pubkey, $error = null, $use_ssl = false)

to

function recaptcha_get_html ($pubkey, $error = null, $use_ssl = true)

Works fine! I think that is not a solution, but can help for now. I hope you will fix this in next update, and integrate new reCaptcha system.

rezgo
replied 6 years ago

Thanks Stefan. I had the same problem and this solved it. With Google pushing for sites to be SSL encrypted, it might be a good idea to make this configurable or set it to true by default.

argyrou argyris
replied 6 years ago

Great! Worked for me as well but on reply-comment, i don’t see any reCaptcha.

Powered by DW Question & Answer Pro