greg dood
asked 8 years ago

Whenever I try to go to a question I get a 404 page not found. I have rebuilt permalinks and it did not fix it. Also, it wont let me select the question details box when creating a question. 
Thanks
url gamecannon.com/board

greg dood
replied 8 years ago

Update: Still not working. Switched to default, saved, then switched back and saved, nothing worked. I am running yoast seo as well.

5 Answers
Guru
answered 8 years ago

Hi @halfshell,
Please rebuild the perma links after setting them to default. This should resolve the issue.
 
Best regards,

greg dood
replied 8 years ago

Am I alright to set them back after rebuilding them? I would rather keep my link structure of gamecannon.com/postname

well wisher
answered 8 years ago

which permalink structure did you chose i recommend using custom structure yoursitename.com/sample-post-name it should resolve the issue
thanks

greg dood
replied 8 years ago

This is the structure my site uses yoursitename.com/sample-post-name

Guru
replied 8 years ago

Once you choose the default after the DWQA installation, you can revert back to any custom structure that you were using previously. This should solve the problem.

greg dood
replied 8 years ago

I have done all this and it still doesn’t work. I am using yoast seo btw.

Guru
replied 8 years ago

why not send your login details along with FTP access details via private answer for further checking.

greg dood
replied 8 years ago

How do I end in a private question?

Guru
replied 8 years ago

Create a new answer and set the status as private which is little icon at the bottom.

greg dood
replied 8 years ago

Ok I sent it via a private answer

Guru
replied 8 years ago

Hi Greg,

I have checked your site and have made a few changes, but it looks like there is some thing preventing the permanent links from taking effect even though the links do work, but when clicking on the archive page, it seems there is trouble. I suggest you remove the plugin and then disable all other pluging and then reinstall DWQA and configure it as it is now done. making sure not to keep the single question slug and the archive page slug the same! 🙂

At the moment these links are all working.

http://gamecannon.com/thread/threads/
http://gamecannon.com/thread/test-thread/
http://gamecannon.com/thread-category/general/
http://gamecannon.com/create-thread/
http://gamecannon.com/thread-tag/tree/

well wisher
answered 8 years ago

hey just checked your site your permalink structure is yoursitename/category-name/post-name
It should be set to yoursitename/post-name to resolve the problem

well wisher
replied 8 years ago

goto>>dashboard>>settings(wordpress one and not dwqa settings)>>permalinks>>and chenge your permalinks settings there
Thanks i hope it helps !!!

greg dood
replied 8 years ago

They were already set to be postname and no category. I tried rotating between the two but it still doesn’t work.

Jackie Lord
answered 8 years ago

@halfshell: We are still waiting for your reply!

Guru
answered 8 years ago

Hi Greg,
http://gamecannon.com/threads/
http://gamecannon.com/thread/ask-v/
http://gamecannon.com/thread-category/general/
http://gamecannon.com/create-thread/
I can see that the permalinks are working just fine now, but it looks like you have lost the theme integration. You can follow the guide here to make it look like your theme: http://designwall.com/guide/dw-question-answer-plugin/#Style_integration
Regards

DominicStaff
answered 8 years ago

Hi, 
Just want to follow up on your question, let us know if there is anything else we could help.
Regards,

Powered by DW Question & Answer Pro