Sunil Dev
asked 6 years ago

I have installed and activated the plugin as suggested. Everything seems fine except the followings –

  1. The comment box is appearing but when I (the admin) type any comment in it and click the button “Add Answer” at the bottom, it takes me to a strange page (A page where everything is blank and ‘0’ appears in top left corner). If there is another button to submit the comment then where it is? There is no any other ‘submit’ button below the comment box. The answer box is working fine. 
  2. There are some buttons below the question title such as “Open” button, “Public” button and “Follow” button. None of this buttons are working. When I click them nothing happens. Other buttons like answered, resolved, closed, etc are working fine. 

Please suggest. I am using a premium theme since from long time and my visitors are addicted to it, so I can’t change the theme. I can’t even think to change the theme for a single minute because there is average 200 visitors all the time throughout the day and night. Switching off my site will cause lose in Ad revenue. 
To find out the issue I have installed wordpress (latest version) on my localhost (on pc using xampp) and tried the DQ Question Answer plugin on other theme and lo everything works fine.
So, my request is, is there any option available which can correct those above issues without need of changing my theme. Please suggest.

1 Answers
DominicStaff
answered 6 years ago

Hi,
I have checked on our demo and still work fine. Firstly, please deactivate  all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one and let us know if you find the problematic plugin(s). Maybe there is a conflict in plugins.
If you still face there issue, you can send me username & password of your site for further checking (via private answer).

Sunil Dev
replied 6 years ago

Thanks for the answer. I have managed to solve the issues. Actually it’s jquery conflict. I updated my theme’s jquery version and everything is fine now.
Now I am having some other issue and hope it does not have anything with my theme or jquery –
1. To avoid spam, I have choose the option, available in settings, to manually approve each question before being published (I am also allowing guest to post question). Now the problem is – when visitor successfully submit their question, they goes to the URL/page of the question they just submitted but since their question is on hold for approval, they are seeing a error page thus make them confuse whether their question got submitted or not. In other hand if I remove the option of manually approving question from settings then every thing works fine.
So tell me how can I solve this. It will be good if I have option to show them a message “Your Question is awaiting for approval” instead of error page.

2. My second question – If I enable ReCaptcha then visitors will have to go through ReCaptcha test before posting any question or answer. That’s good, but when visitors write comments or write down their answer in the comment box (not in answer box) and submit it, then they are easily bypassing the ReCaptcha security.
So tell me how can I secure the comment box from spamming. Is there option available that user commenting on the comment box must go through ReCaptcha or their comments can be hold for approval/moderation.

Please do suggest. Very good plugin, I am planning to create a new question and answer type site with this plugin

Powered by DW Question & Answer Pro